BikePGH!

Message Board Updates and Constructive Ideas

This topic contains 125 replies, has 31 voices, and was last updated by  scott 1 mo.

Viewing 40 posts - 1 through 40 (of 126 total)
 
Author Posts
Author Posts

scott

Private Message

Apr 30 2013 at 5:11pm #

This will be the thread where you can find updates on what we’re doing to address key issues with these forums, and where you give CONSTRUCTIVE feedback. That means 1. be nice 2. be thankful to those putting in the volunteer effort and 3. be patient while these things are being worked on.


rice rocket

Private Message

Apr 30 2013 at 5:16pm #

How about a lock icon to tell us that the other thread is indeed locked? ;)

I said this already in another thread, but bbpress is awful software inside and out. I get that the site is built on WordPress and it was easy to integrate bbpress into it, but there are tons of code bridges that allow real, free open source forum software to be used that have tons of features, excellent stability, and have been iterated on for over 10 years.


Mick

Private Message

Apr 30 2013 at 5:39pm #

To Nathan,

I’m one of the people who has crtiqued some of your work in another thread.

I just want to also say thank you for the work you have done.

Yesterday I sent in an check for my Bike-pgh membership. In part because my frustration with how the board has been running has made me aware of how much the board and Bike-Pgh mean to me.

Thanks.


scott

Private Message

Apr 30 2013 at 5:40pm #

What forum software do you recommend, and what specific code bridges would you recommend? The big issue with changing things over to new forum software would most likely be losing all logins and all past threads. If there were some sort of way to port all that to new forum software then I’m all ears.


cburch

Private Message

Apr 30 2013 at 7:23pm #

scott wrote:What forum software do you recommend, and what specific code bridges would you recommend? The big issue with changing things over to new forum software would most likely be losing all logins and all past threads. If there were some sort of way to port all that to new forum software then I’m all ears.

assuming bbpress uses a MySQL database you should theoretically be able to map all the old content onto a new database with RELATIVE ease. I also know there are more than a few folks round these parts who are way smarter about databases than I am.

My point being that the data should be able to be ported over to whatever solution you choose and therefore shouldn’t be the primary factor in picking the best solution for the forums moving forward.


byogman

Private Message

Apr 30 2013 at 7:46pm #

“assuming bbpress uses a MySQL database you should theoretically be able to map all the old content onto a new database with RELATIVE ease.”

OK, so I’ll dip my toe into this since I’m a developer, but have spent my time as close to the data storage as possible. I’m decently ok at applying some code searching and schema reverse engineering even when logical constraints aren’t expressed in db-land. And to a lesser extent other forms of storage are fine to, it’s just a little more work to get and you may have a tough time getting the sort of meta information that makes this go smoother.

So, if we do find ourselves changing platforms and we need to lift content, I’ll volunteer to help. On one condition. IF AND ONLY IF we can have an environment to qa in. Things can easily get missed with any data migration and it’s much worse when you don’t know the app intimately. So I won’t step into something where I can’t test my work before putting it live. But if I can, I’m here to help.


cburch

Private Message

Apr 30 2013 at 8:26pm #

Yes a solid test plan is a must moving forward.


reddan

Private Message

May 1 2013 at 7:41am #

I’m in the process of setting things up on my host, as I’m pathologically addicted to test environments and version control. I’ll also likely set up some rudimentary issue tracking, probably just a publicly viewable spreadsheet listing what complaints and suggestions have been made, and how they’re being ignored handled.

As regards new forum software, what features are desired, that do not currently exist? I ask not to be flippant, but because moving to yet another solution is a non-trivial endeavor…I wouldn’t choose to change merely because “bbPress is the sux”(even if it is). If there’s defined value to be gained by choosing another package, though, that’s a different story.

Having a solid set of requirements for what is desired is crucial, before anyone could have a meaningful discussion of the costs and benefits associated with another migration.


Benzo

Private Message

May 1 2013 at 2:53pm #

FYI, looks like I’m getting text cutoff on the right hand side on chrome on WIN7 on this thread at the moment. Doesn’t seem to affect a lot of other threads.

http://bikepgh.org/mb/topic/iain-a-boy-hit-by-a-car-while-cycling/


myddrin

Private Message

May 1 2013 at 2:56pm #

Benzo wrote:FYI, looks like I’m getting text cutoff on the right hand side on chrome on WIN7 on this thread at the moment. Doesn’t seem to affect a lot of other threads.

http://bikepgh.org/mb/topic/iain-a-boy-hit-by-a-car-while-cycling/

Same on Chrome/Linux v 26.something.


Drewbacca

Private Message

May 1 2013 at 2:57pm #

The thread cut starts with a photo in quotes…


scott

Private Message

May 1 2013 at 2:58pm #

“Stick topic (to front)” for me doesn’t seem to work. Ideally clicking that would keep the topic at the very top of the page.


buffalo buffalo

Private Message

May 1 2013 at 3:00pm #

I’m having the same problem Benzo reports, also Chrome/Win7. Seems to be related to the wide picture posted on the last page.


Benzo

Private Message

May 1 2013 at 3:18pm #

scott wrote:“Stick topic (to front)” for me doesn’t seem to work. Ideally clicking that would keep the topic at the very top of the page.

I mentioned in the other closed thread that http://bikepgh.org/topics/ shows the pinned threads, but http://bikepgh.org/mb/ does not.

The only way I found this was clicking page 2 from the main screen which takes you to http://bikepgh.org/topics/page/2/ and then clicking page 1 which takes you to http://bikepgh.org/topics/.

However, If you click page 1 from the main screen it keeps you on http://bikepgh.org/mb/ instead of http://bikepgh.org/topics/


Marko82

Private Message

May 1 2013 at 3:59pm #

FYI, the message board looks VERY broken using win9 too. The “forums home” page looks ok, but when you click on a thread the formatting falls apart and you have some weird texed-based looking content.

This has been true since the beginning of the roll out, but I thought I’d mention it again.


srpit

Private Message

May 1 2013 at 4:10pm #

Some threads have the right side cut off for me on an iPad. Other threads don’t seem to be affected.

When I login in, it takes me back to the home page instead of back to the page I was on (like the old message board did). Doesn’t even take me to the message board, but to the site’s home page.

Most paragraphs display with the first two words all the way to the right side instead of the normal left justified format. I have to remember to look far right for the missing words (which is a bit awkward).

On some threads, clicking on the last post (from the forums’ home page) still takes me to the first page of that thread instead of the most recent post.

Thanks for continuing to work on the bugs.


cburch

Private Message

May 1 2013 at 4:15pm #

same text display issues as above on an iPhone, chrome or safari. didnt bother with opera…


buffalo buffalo

Private Message

May 3 2013 at 12:48am #

srpit wrote:On some threads, clicking on the last post (from the forums’ home page) still takes me to the first page of that thread instead of the most recent post.

It seems to me to be that exceptionally long threads break the board’s ability to link directly to the last post.

For example, on Quizbot’s “Oblivious PGH Motorists on video”, both the thread name and the time-since-last-post link currently to an anchor on page 6 of the thread. On “Tag-o-Rama” (138 pages) and “Wheelset of Fortune” (38 pages), these both link to an anchor on the first page.

The 15 page “Cars hitting buildings” and 10 page “Have you made your 311 complaint this week?” do not seem to be affected, but I don’t at a casual glance see any in between to find the breaking point…


pinky

Private Message

May 6 2013 at 12:32pm #

I’ve stayed out of this conversation, but thought I might dip a toes in to ask: does anyone know what has happened to some of the gravatars? I can log in to Gravatar and see mine fine, but it doesn’t show up (for me at least) lately.

To test, here’s the embedded image:

So if that works, why doesn’t it work next to my name?

Thanks to everyone who is working on the board.


Pierce

Private Message

May 6 2013 at 3:43pm #

Hey Dan, can we just setup a public Google Doc to keep track of the forum issues?

Maybe have three columns,

date submitted, problem, status

Like this:

https://docs.google.com/spreadsheet/ccc?key=0AmpE10GKWuFtdHJXZ3JPSEtWNkJwQnY3andtOElrS3c&usp=sharing


reddan

Private Message

May 6 2013 at 4:13pm #

Hey Dan, can we just setup a public Google Doc to keep track of the forum issues?

Maybe have three columns,

date submitted, problem, status

Like this:

https://docs.google.com/spreadsheet/ccc?key=0AmpE10GKWuFtdHJXZ3JPSEtWNkJwQnY3andtOElrS3c&usp=sharing

Already in progress, but thank you!


Pierce

Private Message

May 6 2013 at 4:29pm #

Shall we continue posting bugs to this thread?


Drewbacca

Private Message

May 6 2013 at 6:10pm #

pinky wrote:I’ve stayed out of this conversation, but thought I might dip a toes in to ask: does anyone know what has happened to some of the gravatars? I can log in to Gravatar and see mine fine, but it doesn’t show up (for me at least) lately.

Try what is within your power first, reupload your gravitar and see if that fixes the bug.

If that doesn’t do it, then I’m thinking that there is some sort of parent-control glitch in that admin tools for this site… something meant to censor inappropriate avatars which is getting turned on by mistake.

I looked at the page source for any obvious problems and the generated link redirects to the faceless avatar rather than your actual avatar. So, it’s either generating a bad ID “d5b543932996fba115ad42d14ad0da3f?” or gravatar doesn’t recognize it due to a bug on their end.


Steven

Private Message

May 6 2013 at 10:05pm #

I believe Gravatar works by matching up emails. So check that the email address you’re using at the Gravatar site is exactly the same as the one you use at this site.


Steven

Private Message

May 6 2013 at 10:32pm #

I just edited my post in the Tag-O-Rama thread. It asked if I wanted to include a reason. I typed

Removed “patisserie”, which I’m not sure is the right term.

It updated my post, but the reason doesn’t show. I expected to see a note after it, as on some other boards, like

Edited 11:10 PM by Steven. Reason: Removed “patisserie”, which I’m not sure is the right term.

But I see no indication it was edited, nor the text it prompted me for.


salty

Private Message

May 6 2013 at 11:02pm #

was the “keep a log of this edit” box checked? otherwise there’s no indication the edit happened.


quizbot

Private Message

May 7 2013 at 1:35am #

I was able to remove “cunt” from a post on another thread, and it worked for me. YMMV.


Steven

Private Message

May 7 2013 at 1:49am #

I thought it was checked. But let’s see. No, still no note about editing. I edited this post multiple times, with the box checked or not, with various editing-reason messages.


pinky

Private Message

May 7 2013 at 9:24am #

Hey look – there’s my gravatar! Thanks, Steven.


Pierce

Private Message

May 7 2013 at 3:13pm #

@Reddan

My temporary solution to the login-jumping-back-to-main-page bug is to hit the back button on the browser a couple of times and then refreshing


reddan

Private Message

May 8 2013 at 8:46am #

Folks, here’s a basic form you can use to enter bug reports and suggestions for the Web site: http://bikepgh.org/website-feedback/.

You can also see the current list of items here: http://bikepgh.org/site-requests-summary/


Drewbacca

Private Message

May 8 2013 at 12:28pm #

Is there a hard link for the feedback somewhere? I’d think that the “contact” page under the “about” tab would be a good location for that.


Pierce

Private Message

May 8 2013 at 3:15pm #

It would be cool if this thread was titled “Have you submitted your forum bug this week?”


reddan

Private Message

May 23 2013 at 5:15pm #

As of 5/23/2013, stickies live again. [waves hat in air, mimes riding a bull]

Next up, fixing some glitches with the unread-posts stuff, then maybe tackle the problem where the links for long threads get hosed up.


StuInMcCandless

Private Message

May 23 2013 at 5:41pm #

A purely cosmetic issue: Can the italic font you are using be a little less slanty? It is sometimes hard to read.

FWIW, I’m on a Dell laptop, Win 7, Chrome Version 26.0.1410.64 m.


Ahlir

Private Message

May 23 2013 at 7:04pm #

Italics are designed as such. Oblique (slant) fonts are skewed versions of a (roman) font. The latter tend to be uglier than the former. I’m not a professional but we seem to have an oblique on our hands.

It should be possible to fool with the .css file(s) and specify a nicer face. However I feel it would be a bit of an imposition on reddan to do the work. You could check out the wordpress options and see if anything works better for you.

My only problem with the current slant font is transitions. For example:

… be a little less slanty? It is sometimes …
… be a little less slanty?  It is sometimes …

The first is what you get normally, the second adds a space. In principle this is an easy fix (if that’s the problem).


buffalo buffalo

Private Message

May 23 2013 at 7:41pm #

According to my machine (Win 7+Chrome), the font in use is Droid Sans, and yes, that really is its italic.

IIRC, custom style sheets have been discussed previously…


reddan

Private Message

May 23 2013 at 8:25pm #

It should be possible to fool with the .css file(s) and specify a nicer face. However I feel it would be a bit of an imposition on reddan to do the work.

Not a horrible imposition, but really not my focus.

I volunteered to help fix the nasty bugs and help implement important features…my skills are better suited to creating stuff like the cross-device unread replies tracking feature we added a couple months back, hauling sticky posts out of their grave, or to debugging through the gruesome spaghetti of PHP which is causing the URLs for the Tag-a-Rama thread to be all hosed up.

This is not to say that I’m not happy to help with the CSS and formatting stuff, but colors, fonts, layout, and other elements of the overall site design are really more up to the Bike-PGH staff than to me. To be honest, my sense of aesthetics, if unchecked, would result in something about this exciting:


Pierce

Private Message

May 23 2013 at 9:06pm #

(Grr, logged in and got bumped back to the main page…)

I imagine your aesthetics would suit a lot of us

It kind of reminds me of IRC, which I kind of grew up on


Mikhail

Private Message

May 23 2013 at 10:15pm #

StuInMcCandless wrote:A purely cosmetic issue: Can the italic font you are using be a little less slanty? It is sometimes hard to read.

FWIW, I’m on a Dell laptop, Win 7, Chrome Version 26.0.1410.64 m.

Stu,

Fonts are installed on your machine. HTTP request-reply passes information on font (name, size, attributes) and code points (now days UNICODE using usually UTF-8 as a coding scheme) and css. Your browser does everything else.

Viewing 40 posts - 1 through 40 (of 126 total)
 

You must be logged in to reply to this topic.