BikePGH!

Message Board Usability

This topic contains 180 replies, has 39 voices, and was last updated by  Vannevar 1 yr, 6 mos.

Viewing 21 posts - 161 through 181 (of 181 total)
 
Author Posts
Author Posts

Steven

Private Message

Mar 18 2013 at 4:37pm #

Nathan, I noticed something that might help you track down the issue with last-unread-post failing on certain long threads.

Using the ?p= URL syntax to locate a specific post, I found that it works fine in the Tag-O-Rama 2 thread for all posts except those on the very last page. For those it goes to the first or second page instead. I’m guessing the glitch causing this is the same glitch that makes last-unread-post fail sometimes.


jonawebb

Private Message

Mar 19 2013 at 9:17am #

BTW, minor problem — when I open a thread I’ve read before the positioning shows not the first unread post, but the last read post at the top. Normally this does not matter and is sort of convenient since it gives me context, but when the first unread post is on a new page the new page is not opened; instead I see the last read post on the previous page. So unless I notice there’s a new page there I don’t see any new posts. It would be better to position things so I see the first unread post at the top of the page, always.


salty

Private Message

Mar 19 2013 at 10:16pm #

I still have the text wrapping problem I reported 2 weeks ago. It makes the threads where it happens on frustratingly unusable and there is no workaround I can find.


Benzo

Private Message

Mar 21 2013 at 6:59am #

It seems that new youtube links on the Bike Music Video thread seem to be set to a width too small to actually play videos without going to youtube. They just say “Video Player Too Small”. I don’t know if this is due to the way the poster posted the video or the auto formatting done when you paste a youtube link. The first few posts in that thread are ok, but after a certain point, all the videos are smaller and can’t be played.


StuInMcCandless

Private Message

Mar 24 2013 at 8:07pm #

Earlier today, I had the most miserable time trying to get a link to work.

Top of page 35 of the Wheelset thread
(http://bikepgh.org/mb/topic/play-wheelset-of-fortune/page/35/),
I tried to link back to a particular post about halfway down the page. I could not get that link to work! The link I tried to use first was captured by clicking on the “#” under my name. I almost never have a problem posting links; I can almost do it in my sleep. No typos.

The solution appears to be to hard-code the page number as part of the link. But isn’t the number of the post unique? Isn’t that enough to pull it out of whatever database it’s in? (Sorry, I don’t know the structure, but why should that matter?) I needed both the page number and the post number.

If this is what’s necessary, then please provide it in that “#” thing that is supplied.

Edit: I just looked at the value for this post. Seems to be there.

In fact, it looks like this has been addressed before, in this post.

Yeah, worked fine that time.


Ahlir

Private Message

Mar 26 2013 at 1:40pm #

The website is looking great!

One thing I’ve noticed is that there doesn’t seem to be a direct way to get to the message board (bikepgh.org/mb/).

There’s a section called “the Forums” that features current items but there’s no way to get to the page itself. I get the sense that unless you are interested in one of the 4 topics that happen to be listed you may not bother to click through.

So anyway:

1. The (clickable) header “[BikePGH] Message Board” ought to be on the front page, as part of the “Get Involved” stack.

2. The current-items display might be prefaced with “Latest Posts”. (Also, adding posting times might help signal that this board is a happenin’ place.)

3. This might just be me, but the Msg Board seems more like a “Forum” in the singular (unless the old subdivisions are hiding someplace).

Btw for some reason the “Becoming a Member” and “Volunteer” captions are centered but the other items are left-flushed. It looks a bit off. Make all of them the same?

Picky, I know…


Steven

Private Message

Mar 26 2013 at 3:27pm #

I’m not sure I agree about the “Becoming a Member” and “Volunteer” captions. Those two are buttons, while the rest are merely non-clickable headings. The two types shouldn’t be made to look any more similar. (If anything, they should look more distinct, and more like buttons.)

Agree about the rest. Good points.

It’s been a while since we’ve heard from Nathan. Hope he hasn’t been squandering his time working on projects that pay actual money, when he could be working on this site for free. Shelter and food are nice, but hello, we’ve got links that don’t work right. Priorities, man.


StuInMcCandless

Private Message

Mar 26 2013 at 4:24pm #

The message board is the first entry under the Resources pull-down. I’ve used that a time or two, and it’s easy enough to tell people about via email even when you don’t have the link.


Steven

Private Message

Mar 26 2013 at 5:01pm #

Yes, but the list of recent forum posts at the bottom of the home page should have a link to the rest of the posts in the same part of the home page. You shouldn’t have to scroll back up to the top and look for it.


virb

Private Message

Mar 29 2013 at 9:32pm #

Long-time lurker, just actually signed up for a message board username today — I can’t figure out how to change my avatar. Am I missing something? There doesn’t seem to be any option to change it in the “Your Account” section (just Name, Contact Info, etc.)

Any help? Am I just totally missing it?

Thanks!


Steven

Private Message

Mar 30 2013 at 2:27am #

This thread explains how to upload your image to gravatar.com.

(Maybe the “Your Account” page should explain this.)


virb

Private Message

Mar 30 2013 at 9:59am #

Aha! Thanks for the help!


Ahlir

Private Message

Mar 30 2013 at 9:00pm #

Wow. Very nice.

I like how the color coding of the headers is starting to work. Putting the member/volunteer buttons up top makes those opportunities that much more salient.

I would still think that “Get Involved” is too diffuse, especially now that the member/volunteer buttons have moved. Maybe something like “What’s Happening” would communicate the intent better.

I agree with Steven that the message board feed should somehow lead the visitor to the right place. I’m not sure of how to work that in into the design. But labeling it “Message Board(s)” might help to tie it to the menu item in Resources (or, if you want, just call that item “The Forums”; I promise that I won’t complain that the correct plural of forum is fora…)

Finally (and isn’t there always a “finally”?), it might help if the “More from our blog” button didn’t look so much like a banner. Maybe flip the triangle thingie to point up? Or narrow the banner? At least use a suitable glyph. At this time it doesn’t communicate “buttonability”. Or maybe the blog, forums and events section could just end with a “See more …” button (say) the width of the column.

To Stu: I don’t see these posts as complaints. It’s just user feedback, hopefully of some use to Nathan. Since this website is volunteer work this is how all that usability stuff is going to happen (i.e., there’s no budget for testing). It’s part of “Get Involved”, I guess.

Nathan: if you need a beer or two, or a case. Let me know and we’ll work it out.


StuInMcCandless

Private Message

Mar 31 2013 at 9:00am #

This is less a Nathan thing than a Scott or Erok or whoever-on-staff thing:

It would help if the board had a sticky thread that had some basic how-to stuff in it. In fact, I have a sheet of paper I’ve scribbled some ideas of what to put and in what form. That first post on that thread would need to have enough info to inform, without also being so long or dense as to overwhelm.

PM me and I can go into more detail. But it would have helped virb, and I think would help get more new folks on the board and participating. Seems to me we used to get a lot more new people than we do now, and this might be a part of that.


buffalo buffalo

Private Message

Apr 1 2013 at 5:30pm #

apparently there is something special about a thread’s first post that it gets to quote twitter posts properly and the rest of us lowly peons don’t. See, for example, the b.rad’s post at http://bikepgh.org/mb/topic/another-hit-and-run-on-liberty-ave/#post-0 vs. mine at http://bikepgh.org/mb/topic/blocked-bike-racks/#post-267252

some kind of documentation–or at least an interstitial “hey, some of your code’s gonna get dropped—post as is [OK] or rewrite [Cancel]?”–might’ve been nice.


salty

Private Message

Apr 5 2013 at 11:56pm #

Will the text wrapping issue I reported a month ago ever be fixed? I’m definitely not using the board as much and that is at least part of the reason. Most of the other issues I can live with but having text cut off with no way to scroll/zoom/etc to see it is just irritating.


jonawebb

Private Message

Apr 8 2013 at 10:08am #

BTW, why, oh why, haven’t you made the “image” button larger above the text box? Just make it say “Click here to add an image”. It seems like such an easy thing to do, and it would eliminate a lot of “I can’t figure out how to upload an image here” posts, which are pretty frequent, especially from people who just got their bike stolen. Please fix this!


Pierce

Private Message

Apr 8 2013 at 3:38pm #

Might have already been discussed, but I hate logging in on a thread to comment, and then getting bumped back to the main BikePGH page


Mick

Private Message

Apr 8 2013 at 11:24pm #

salty wrote:Will the text wrapping issue I reported a month ago ever be fixed? I’m definitely not using the board as much and that is at least part of the reason. Most of the other issues I can live with but having text cut off with no way to scroll/zoom/etc to see it is just irritating.

+1


Mick

Private Message

Apr 12 2013 at 12:42pm #

People talk about there being an icon/button for posting picutres.

I have IE8 and I see no such thing.

People are fairly clear about where it should be, and there is nothing there in IE8. I’m not just missing it.


Vannevar

Private Message

Apr 21 2013 at 11:02pm #

Pagination of time-sequenced posts

I have a problem with continuing through the pages of previous posts.

When I start on the “main forum page”, the URL is:
http://bikepgh.org/mb/ and at the bottom of the page, the oldest post is 1 week and 4 days old.

But when I progress to the second page of posts, by clicking either the “2” or the “RTY” (right arrow thingy) at the bottom of the page, the new page has a URL of

http://bikepgh.org/mb/forum/bike-advocacy-and-safety/page/2/

and the top of the page displays a headline of
Forum: Comments Ideas Actions Alerts
and the most recent post at the top of the page is 1year 7 months old.

Something seems awry. It seems unlikely that the list of posts jumps from 1week4days old to 1year7months old.
Thanks, V.

Viewing 21 posts - 161 through 181 (of 181 total)
 

You must be logged in to reply to this topic.